Welcome to the MapMan Family of Software Forum

Please do not hesitate to register and post your question.

Don't forget to subscribe to your posted message so you get notified on updates.
Every question you post will help others and or enhance the software!

Post a question,   post a bug!

Welcome to the MapMen Family of Software Forum Welcome to the MapMen Family of Software Forum

MapMan Bugs

Execution halted during normalisation after counts had been generated

Execution halted during normalisation after counts had been generated
execution halted during normalisation
2/18/13 11:45 PM
Does anyone know what this means?
I used RobiNA to generate counts from some BAM files that i generated with Tophat, it then automatically starts the normalisation opions of either DESeq or EdgeR. I chose the EdgR option and then got the following message before the software closed down...

Loading required package: limma
Calculating library sizes from column totals.
[1] -1 0 0 0 0 0 0 1
[1] "computing contrast MS_5-GS_0"
Error in glmLRT(d, fit, contrast = comp) :
First argument is no longer required. Rerun with just the glmfit and coef or contrast arguments.
Execution halted

RE: Execution halted during normalisation after counts had been generated
2/19/13 9:54 AM as a reply to Richard John Barker.
Hi Richard,

the message indicates that the R code that RobiNA tried to execute is no longer compatible
with the Bioconductor version that you were running it on. This should only be possible if
you were using RobiNA on a linux machine using an R/Bioconductor installation that was
not bundled with the RobiNA package ( i try to keep the R code in sync with the R/Bioconductor
version bundled with the mac and windows versions of the RobiNA package).

It seems like you have a version of R/Bioconductor installed in which some of the function
signatures differ from the version RobiNA expects - hence the error message was issued.

It would be very helpful if you could tell me if the above is true and also send me some
details about your RobiNA and R installations: Which versions of RobiNA and R do you
have installed on your system?

In R, you can find out by first starting R, then loading edgeR by typing


and then typing


please send be the output of the sessionInfo() call

the version(s) that the current release of RobiNA was designed to run with are R-2.15.0 and edgeR-2.6.12

best greetings,

RE: Execution halted during normalisation after counts had been generated
4/4/13 2:30 AM as a reply to Marc Lohse.
Hi Marc

Correct, the virtual linux machine that i used to had another version of R (it was the latest release in December) that was incompatible, so i uninstalled it and then used RobiNA by itself; it worked great! Sorry i couldn't provide you with the information you requested but the virtual machine it was running on was shut down for updates by the iPlant collaborative.

I used fastx tools to trim my fastq file and then generated BAM files using TopHat2/Bowtie2. I then tried to use RobiNA to generate counts per gene/isoform and perform normalisation using EdgeR and DESeq. Unfortunately after successfully loading the BAM files into the RobiNA, i then try to use EdgeR/DESeq but it was unable to annotate the genes/isoforms and then at the results stage the only identifiers are the chromosomes.

Do you know how i can make it recognise the genes/isoforms when i import BAM files generated in other packages?

Thanks, Richard